Home

Alimentatore 6.3V per filamenti con un vecchio alimentatore per PC

Attenzione, alcune delle procedure che vedete qui implicano il lavoro con cavi in tensione di rete scoperti e quindi un pericolo mortale!!! Ponete quindi sempre la massima attenzione a quello che fate!!

Mi serviva un  alimentatore stabilizzato da 6.3V che potesse erogare almeno 20A per alimentare i filamenti di alcune valvole.
Il classico regolatore in serie ( vedi figura qui sotto )
 

oltre a richiedere una quantità industriale di condensatori per il primo livellamento e dei diodi robustissimi, mi avrebbe richiesto un trasformatore con un secondario di almeno 8.2V per supplire alle cadute di tensione sul regolatore ed una corrente di 20A minimo, inoltre  avrebbe dissipato circa 45W sul regolatore, rendendolo un forno.
Passando in laboratorio, in un angolo ho visto un vecchio PC e mi è venuta un' idea:  l'alimentatore switching del PC è stabilizzato e fornisce già un sacco di tensioni utili, quindi perchè non provare a modificarlo???

Bene, ecco il nostro alimentatore:

non ci si capisce molto, ma i fili inuscita seguono uno schema di colore ben preciso che o conosciamo oppure possiamo facilmente recuperare in rete e che riassumo qui sotto.

Color Signal Pin Pin Signal Color
Orange +3.3 V 1 13 +3.3 V Orange
+3.3 V sense Brown
Orange +3.3 V 2 14 ?12 V Blue
Black Ground 3 15 Ground Black
Red +5 V 4 16 Power on Green
Black Ground 5 17 Ground Black
Red +5 V 6 18 Ground Black
Black Ground 7 19 Ground Black
Grey Power good 8 20 Reserved N/C
Purple +5 V standby 9 21 +5 V Red
Yellow +12 V 10 22 +5 V Red
Yellow +12 V 11 23 +5 V Red
Orange +3.3 V 12 24 Ground Black

Se osserviamo bene inoltre ci sono un sacco di componenti conosciuti, che sono di uso comune e che poco hanno a che fare con l'alimentazione switching, ma uno si riesce a distinguere:

il TL494 che è un controller switching e cercando in rete si trova facilmente il datasheet che potete scaricare qui.

http://www.onsemi.com/pub_link/Collateral/TL494-D.PDF

dal datasheet in fig.14 vediamo che l'amplificatore di errore più comunemente usato è quello che fa riferimento ai peidini 1 e 2, cercando in rete altri schemi che usano il medesimo circuito integrato, si vede  che effettivamente al 99%  si usa il piedino 1 per controllare la tensione.

Seguendo il percoro dal piedino 1 sia guardano lo stampato sotto che mettendo un puntale del multimetro settato su ricerca continuità ( quello che suona ) sul piedino 1 e poi andando per tentativi finchè non suona, ho verificato che il circuito di controllo era quello segnato in rosso, dove ad R1 di fig. 14 del datasheet corrispondono i componenti segnati in blu ed a R2 corrispondono i componenti segnati in verde.

Qui il primo dilemma: le due resistenze verdi sono in parallelo, quindi valgono come la sola R2, ma le due resistenze blu che sono dove dovrebbe essere  R1 sono collegate a piste diverse.
Con cautela, ho acceso l'alimentatore ( per accenderlo basta cortocircuitare i fili verde - power ON ed uno dei neri GND -) ed ho verificato che quella più in alto nella foto fa capo ai 12V e quella più in basso fa capo ai  5V
le due resistenze verdi sono in parallelo per un valore di 17,8KOhm, mentre quella relativa ai 12V è da 27KOhm e quella relativa ai 5V da 4.7KOhm.

la fig. 14 del datasheet ci da la formula per calcolare la tensione in uscita, ma non conosciamo Vrefche però è 4V circa  e sostituendo i valori nella formula vediamo che mentre la resitenza dei 5V ha senso, quella dei 12 non darebbe alcun risultato utile.
 Rialcolando vediamo che le resitenze verdi per farci ottenere ciò che volgliamo devono essere di  circa 8KOhm.

Togliamo quindi le resistenze verdi


e le sotituiamo con un  potenziometro multigiro da 20KOhm


il primo test ci ha dato buoni risultati: la tensione ha iniziato a seguire il movimento del potenziometro, ma quando arrivava a 5.9V l'alimetatore andava in protezione senza apparente motivo, poi guardando meglio ho notato che i due diodi vicini alle resistenze che vanno ai 5 ed ai 12V erano degli zener, e quello relativo ai 5V era di 5.9V, cioè la tensione a cui il circuito andava im protezione. Ho dedotto che quindi tale zener era  una protezione.


Ho quindi staccato i due zener e come per incanto la tensione è riuscita a salire fino a 6.3V



nel frattempo ne ho pure approfittato per prendere una tensione di rete e portarla ad un relè che verrà eccitato dai 5V ( filo viola ) e andrà ad alimentare gli altri circuiti ausiliari.

Ora possiedo un simpatico alimentatore che mi fornisce le seguenti tensioni:

Nero: comune ( massa )

arancione: 4.3V 30A max
viola: 5V 1A max - continuo
rosso: 6.3V 45A max
giallo: 14.4V 25A max
Bianco: -5.6V 1A max
Blu: -13.2V 1A max

 non male!!

 

la stessa identica modifica si può fare sui più comuni alimentatori per PC, poichè anche se cambia l'integrato controllore switching, il sistema è lo stesso e basta trovare i pin relativi al comparatore per risolvere il problema